• Auteur : Jeff Point [dolichocéphale]
  • Date : 16 décembre 2005 (31 août 2006)
  • Licence : Creative Commons BY-NC-SA link_license
  • Logiciel : zenphoto (Notice Framasoft)

Installer Zenphoto sur Free

Vous êtes abonnés à Free [1] et vous voulez partager vos photos sur internet, alors prenez 10 minutes pour lire ce tutoriel.

Grâce à Zenphoto, vous découvrirez que vous pouvez transformer votre espace d’hebergement en une formidable galerie photographique. Et comme un exemple vaut mieux qu’un long discours...

Le tutoriel vous propose notamment d’adapter les principaux fichiers de configuration (config.php et functions.php) de Zenphoto.

Ce document est à mettre entre toutes les mains, même celles de débutants.

[1] Ce tutoriel peut être adapté à tous les hebergeurs gratuits ou payants

Commentaires

<< Poster un message >>
:: question :: précision :: avis :: commentaire :: bug ::

Installer Zenphoto 1.1.7 sur Free , le 25 août 2008 (3 rép.)

Installer Zenphoto 1.2.3sur Free , le 6 février 2009

cela marche pas avec Zenphoto 1.2.3

Installer Zenphoto 1.1.7 sur Free , le 6 octobre 2009 par sherka

Effectivement, le 1.2 ne marche pas sur free !

Installer Zenphoto 1.2.6 sur Free , le 10 octobre 2009 par Cacatoes

Si si ça marche, voyez par expl ce topic : http://zenbien.com/infos/viewtopic.php ?id=584 (ça c’est pour la 1.2.5)

Il y a quelques modifications à faire dans les fichiers d’installation de zenphoto.

Je n’ai pas encore bien testé que tout fonctionnait.

Je suis en train de mettre la 1.2.6.

Répondre à ce message

Ce tuto n’est plus adapté ... , le 15 avril 2007 par Olivier (0 rép.)

J’ai essayé d’installer en suivant ce tuto ... sans succès. J’ai fait des recherches et j’ai trouvé le tuto adapté à l’adresse .

Allez y faire un tour et redevenez ZEN.

Olivier

-----> Installation de Zenphoto 1.0.5 & 1.0.6

Répondre à ce message

Créer le tuto si le wiki de frama , le 15 avril 2007 par Olivier (0 rép.)

Bonjour, ZenPhoto évolue tous les jours, le tuto doit également évoluer, donc le mettre sur le wiki de fRamasoFt. Olivier

Répondre à ce message

Installer Zenphoto sur Free , le 29 décembre 2006 par Patrick C. (1 rép.)

Bonjour, juste une petit suggestion pour améliorer le tuto : lorsque dans le fichier functions.php on demande de remplacer les lignes 9 à 16, il serait bon d’indiquer le texte d’origine. En effet, si j’avais suivi bourinnement les numérotations, je n’aurai pas remplacé les bonnes lignes. De même pour l’autre texte à remplacer.

Cordialement,

Installer Zenphoto sur Free , le 15 avril 2007 par Olivier

Bonjour Patrick,

Justement, j’essaie d’installer zenphoto sur free ( ?!?) et je n’y connais rien en php : quelles sont les lignes à remplacer ?

Merci pour ton aide, Olivier

Répondre à ce message

Proteger l’accés par un mot de passe ? , le 20 juillet 2006 (1 rép.)

Comment peut-on protéger l’accés au gallery par un login et mot de passe ? Pour éviter que tout le monde accéde a certaines gallerie photo ? je suis sur Free !! Merci d’avance pour votre aide

Proteger l’accés par un mot de passe ? , le 9 septembre 2006

je pense qu’avec un .htaccess ca fonctionne. pour free la syntaxe est particuliere. chercher ds la faq de free

Répondre à ce message

Installer Zenphoto 1.0.3 sur Free , le 11 juillet 2006 par lapelloche (1 rép.)

Bonjour, Quelles sont les modifs a apporter pour l’install (ou la mise a jour) de la derniere version 1.0.3. J’ai essayé mais sans succes ! J’utilise la 1.0.1 sans soucis mais je n’y connait strictement rien en PHP. Merci pour le tuto 1.0.1 Merci.

Installer Zenphoto 1.0.3 sur Free , le 21 septembre 2006 par avanceRapide

Bonjour, voilà un tuto sur la 1.0.3 http://zenbien.com/infos/viewtopic.php ?id=119

Répondre à ce message

Probleme lors de l’ajout de commentaire , le 27 mars 2006 par Hugues (0 rép.)

Lors de l’ajout d’un commentaire sur une image, ces deux messages d’erreurs apparaissent (probleme de headers) :

Warning : Cannot modify header information - headers already sent by (output started at /var/www/free.fr/1/1/artmoves/index.php:6) in /var/www/free.fr/1/1/artmoves/zen/template-functions.php on line 67

Warning : Cannot modify header information - headers already sent by (output started at /var/www/free.fr/1/1/artmoves/index.php:6) in /var/www/free.fr/1/1/artmoves/zen/template-functions.php on line 75

Le commentaire est quand même pris en compte, mais c’est embêtant pour les visiteurs... Un peu d’aide ?

Répondre à ce message

Merci ! , le 26 mars 2006 par Omnisilver (0 rép.)

Je viens de suivre le tutoriel, j’ai du mettre 10 minutes à effectuer l’opération, du beau boulot ;)

Seul regret : zen est en anglais seulement et ne semble pas être localisé ... j’ai vu passer une version française dans le coin, je vais essayer de la récupérer.

Répondre à ce message

Installer Zenphoto sur Free , le 21 mars 2006 (1 rép.)

"il faut activer votre base de données MySQL à cette page : http://subscribe.free.fr/acces/createbase.html"

le lien ne fonctionne pas, et je n’ai aucune idée de l’endroit où est cette page... pouvez vous m’aider ?

merci d’avance.

-----> lien free

Installer Zenphoto sur Free , le 22 mars 2006 par Ben

Bonjour,

Pour accéder à vos comptes et paramètres free vous pouvez aller ici : http://subscribe.free.fr/login/

Une fois connecté avec votre Identifiant/mot de passe, vous accédez aux options des comptes. En bas de page se trouve la rubrique Php-MySql avec la possibilité d’activer la base de données.

Ben

Répondre à ce message

Installer Zenphoto sur Free Mise a jour 0.9->1.0.1 , le 7 mars 2006 par JeanP (1 rép.)

Salut,

jai installe la version 0.9 tout est ok et je voudrais faire une mise a jour vers 1.0.1b. Sur le site de zenphoto il explique la procedure. Est ce que cette procuedure fonctionne ? ou faut il faire quelque actions comme modifier le fichier functions.php ou autre actions ?

merci a+

Installer Zenphoto sur Free Mise a jour 0.9->1.0.1 , le 20 mars 2006

J’ai fait le test, pour passer de la 0.9 à la 1.0.1b il suffit de reprendre le tutorial de 1.0.1b sans faire la partie initialisation des bases et de lancer le script /zen/upgrade.php au lieu de /zen/setup.php

pour moi cela à marcher !

Répondre à ce message

Installer Zenphoto sur Free , le 23 février 2006 par The Liar (1 rép.)

Je n’arrive pas à "uploader" un fichier zip . Le chargement commence mais il y a ensuite une erreur dans functions.php à la ligne 113... Que faire ?

Merci par avance

Installer Zenphoto sur Free , le 26 février 2006 par dolichocephale

la fonction zip n’est pas disponible chez Free, il faut uploader les photos une par une ou par FTP.

Répondre à ce message

problème avec le fichier admin-functions.php , le 12 février 2006 par choupette (3 rép.)

Bonjour, toute l’installation se passe bien jusqu’au point 8 du tutorial concernant le fichier admin-functions.php. Je n’ai que quelques lignes de code et je ne trouve donc pas de ligne 149. Quelqu’un peut-il m’aider ? Merci beaucoup !

problème avec le fichier admin-functions.php , le 16 février 2006 par kongasiou

c’est quoi ces lignes de code ?

Dean

-----> site

problème avec le fichier admin-functions.php , le 19 février 2006

Réponse à Dean :

Je suis sensée remplacer la ligne 149 par : echo "\n " ;

Or moi, quand j’ouvre le fichier, je n’ai que cette ligne (certes longue) : " ; echo "\n " ; echo "\n " ; echo "\n " ; /** * Print a link to a particular admin page. * * @param $action The action page that to which this link will point. E.g. edit, comment, etc. * @param $text Text for the hyperlink. * @param $title Optional title attribute for the hyperlink. Default is NULL. * @param $class Optional class attribute for the hyperlink. Default is NULL. * @param $id Optional id attribute for the hyperlink. Default is NULL. * * @author Todd Papaioannou (lucky@luckyspin.org) * @since 1.0.0 */ function printAdminLink($action, $text, $title=NULL, $class=NULL, $id=NULL) printLink("admin.php ?page=". $action, $text, $title, $class, $id) ; /** * Print a link to the album sorting page. We will remain within the Edit tab of the admin section. * * @param $album The album name to sort. * @param $text Text for the hyperlink. * @param $title Optional title attribute for the hyperlink. Default is NULL. * @param $class Optional class attribute for the hyperlink. Default is NULL. * @param $id Optional id attribute for the hyperlink. Default is NULL. * * @author Todd Papaioannou (lucky@luckyspin.org) * @since 1.0.0 */ function printSortLink($album, $text, $title=NULL, $class=NULL, $id=NULL) printLink(WEBPATH . "/zen/albumsort.php ?page=edit&album=". urlencode( ($album->getFolder()) ), $text, $title, $class, $id) ; /** * Print a link that will take the user to the actual album. E.g. useful for View Album. * * @param $album The album to view. * @param $text Text for the hyperlink. * @param $title Optional title attribute for the hyperlink. Default is NULL. * @param $class Optional class attribute for the hyperlink. Default is NULL. * @param $id Optional id attribute for the hyperlink. Default is NULL. * * @author Todd Papaioannou (lucky@luckyspin.org) * @since 1.0.0 */ function printViewLink($album, $text, $title=NULL, $class=NULL, $id=NULL) printLink(WEBPATH . "/index.php ?album=". urlencode( ($album->getFolder()) ), $text, $title, $class, $id) ; /** * Print the thumbnail for a particular Image. * * @param $image The Image object whose thumbnail we want to display. * @param $class Optional class attribute for the hyperlink. Default is NULL. * @param $id Optional id attribute for the hyperlink. Default is NULL. * * @author Todd Papaioannou (lucky@luckyspin.org) * @since 1.0.0 */ function printImageThumb($image, $class=NULL, $id=NULL) echo "\n getImageID() ."\" src=\"" . $image->getThumb() . "\" alt=\"". $image->getTitle() . "\"" . ((zp_conf(’thumb_crop’)) ? " width=\"".zp_conf(’thumb_crop_width’)."\" height=\"".zp_conf(’thumb_crop_height’)."\"" : "") . (($class) ? " class=\"$class\"" : "") . (($id) ? " id=\"$id\"" : "") . " />" ; // TODO : This is a copy of the function in template-functions. Refactor at some point function printLink($url, $text, $title=NULL, $class=NULL, $id=NULL) echo "overview" ; echo "\n

Je pense donc qu’il y a un bug

problème avec le fichier admin-functions.php , le 19 février 2006

J’ai résolu mon problème. Merci !

Répondre à ce message

Probleme miniature , le 19 janvier 2006 par nainnain6 (10 rép.)

LOL c’est encore moi quelqu’un saurait_il régler le probleme des miniatures qui ne s’affichent pas ?

merci

Probleme miniature , le 19 janvier 2006 par kongasiou

Tu n’as pas de miniature, mais, même dans la partie admin ?, sinon est-ce ce que tu as un lien à la place de la miniature ? Peux tu donner l’adresse du site pour voir le pb ? tu as suivi le tutoriel pour l’install ?

Dean

Probleme miniature , le 19 janvier 2006 par kongasiou

As tu des fichiers dans le dossier cache du serveur ? quel est l’attribut de fichier de ce dossier cache ?

Dean

Probleme miniature , le 19 janvier 2006 par nainnain6

J’ai un lien a la place des miniatures je vais voir pour le cache :)

Probleme miniature , le 19 janvier 2006 par nainnain6

Le fichier cache contient un fichier theme.txt et le chmod 700 (sa ne pourrait pas venir d’un pb de taille d’image ou un truc dans le genre...de plus je suis chez free et je crois que certain attribut son inchangablepeut etre que je me trompe remarque)

Probleme miniature , le 19 janvier 2006 par nainnain6

chmod effectivement bloqué sur free tu crois que c en rapport avec mon probleme ?

Probleme miniature , le 19 janvier 2006 par nainnain6

bon aparamant aucun rapport vue que doli est aussi sur free et a les miniature la je tourne en rond Oo

Probleme miniature , le 20 janvier 2006 par kongasiou

Bon

Vide completement tes dossiers "albums" et "cache" ( efface tout ce qu’il y a dedans )

Va à l’adresse http://sql.free.fr et vide tes 3 tables correspondantes à zenphoto ( ne te trompe pas ! )

......

Il n’y a pas de raison pour que ça ne fonctionne pas si tu suis les démarches correctement.

Pour faire ça au mieux, tu efface carrément tous tes fichiers sur serveur et tu les remets pour refaire une install au propre

Dean

Probleme miniature , le 20 janvier 2006 par nainnain6

Wai mais non pasque j’ai déja mis lomtem pour upload toute mes photo alor il n’est pas question de tou effacer

+

Probleme miniature , le 20 janvier 2006 par nainnain6

Bon j’ai tout laissé tombé et coppermine est beaucoup mieu je trouve voila et mercid e votre aide

Probleme miniature , le 22 janvier 2006 par kongasiou

C’est dommâge...enfin si tu as trouvé ton bonheur !

Il semblerait que le problème venait du fichier functions.php, pour ceux qui auraient le même soucis. http://www.zenbien.com/infos/viewtopic.php ?id=22

Dean

-----> http://zenbien.com/infos

Répondre à ce message

Merci , le 19 janvier 2006 par Ben (1 rép.)

Merci pour ce guide, simple, concis, efficace ! Il faut le dire quand les choses sont bien faites !

Merci , le 19 janvier 2006 par depassage

Oui, bravo !!

et Merci

Répondre à ce message

SErait il possible de pas avoir de redimensinnemen de l’image ??? , le 19 janvier 2006 par nainnain6 (1 rép.)

lol tou est dans le titre

SErait il possible de pas avoir de redimensinnemen de l’image ??? , le 19 janvier 2006 par nainnain6

^^dsl sur ce coup la j’ai été un boulet je crois sry

Répondre à ce message

Probleme d’instalation , le 17 janvier 2006 par nainnain6 (7 rép.)

Bonjour donc moi toute l’instalation ces bien passé mais au moment d’aller administrer je recoi ce msg d’erreur

Error : The ’albums’ directory cannot be found or is not readable

alors si quelqu’un pouvait m’éclairer pasque je ne sait pas trop quoi faire merci d’avance

Probleme d’instalation , le 18 janvier 2006

salut

Essai de créer un dossier ( nomme le comme tu veux ) dans le dossiers albums, et mets un fichier photo .jpg dedans.

As tu bien fait les modifs du fichier functions.php ?

quel est ta version ?

Probleme d’instalation , le 18 janvier 2006 par kongasiou

Voir sur le site zenphoto

http://www.trisweb.com/archives/category/zenphoto/

"

The ‘albums’ directory cannot be found or is not readable means that you have your ‘server_path’ variable wrong. This thread shows how to find out the right path.

"

as tu bien mis mode rewrite sur false ? verifies bien functions.php

http://zenbien.com/infos/viewtopic.php ?id=4

Dean

Probleme d’instalation , le 18 janvier 2006

Bon la première solution n’a pas marché arff et la deuxieme non plus bon c’est vrai que server path etc j’ai un peu de mal a me familiarisé avec mais pourtan je ne pense pas avoir fait d’erreur et le probleme c’est que la plupart des explication au sujet de ce probleme son en anglais et mon niveau d’anglais laisse quelque peu a désirer lool j’èspère quand meme trouver une solution je v continuer a creuser merci

Probleme d’instalation , le 18 janvier 2006 par kongasiou

Je veux bien t’aider mais tu ne réponds pas à mes questions.

As tu bien renseigné config.php ( surtout le mode rewrite )

sinon pour la modif tu peux remplacer ton fichier functions.php par celui modifié ci-joint http://kongasiou.free.fr/functions.zip

On va y arriver c’est une question de temps

@+ Dean

-----> http://zenbien.com/infos

Probleme d’instalation , le 19 janvier 2006

Lol c’est vrai je n’avais pas été tres clair dans mes explications mes jai effectivement changé les variables du fichieer config et function mais bon peut etre ai je laissé des erreurs je vais donc tenté avec ton fichier je vous tient au courant merci nainnain6

Probleme d’instalation , le 19 janvier 2006 par nainnain6

Bon j’ai tout repri a zéro et sa a l’air de marché donc merci beaucoup mais lol pour le moment mes photos s’affcihe pas en mniature ^^ alors si jamis j’arrive pas a régler ce probleme je créerai un new poste

merci

Probleme d’instalation , le 6 octobre 2006 par ken

Bonsoir !

J’ai le même soucis, j’ai recup cette version :

zenphoto-1.0.1b-fr le theme : par defaut FREE en FAI

Donc j’ai modif le fichier config (login etc...)

Mais une fois que je clique administrate, j’ai ce mess d’ereur !

Un peu d’aide siouplait !

Merci par avance !

Répondre à ce message

Merci , le 17 janvier 2006 (1 rép.)

Merci pour ce tutoriel. Tip top, 5 minutes pour installer ma galerie photo.

Merci , le 18 janvier 2006

C’est coOL !!, alors pratique ?, moi j’hésite un peu pour essayer...

Répondre à ce message

Installer Zenphoto sur Free , le 15 janvier 2006 par dolichocéphale (6 rép.)

J’ai mis à jour le tutoriel pour l’installation de Zenphoto sur Free, il fonctionne pour la version 1.0.1 beta.

Je vais le signaler à Framasoft afin qu’ils mettent la nouvelle version de ce tutoriel. En attendant, il est disponible ici :

-----> Installation de Zenphoto 1.0.1 beta sur Free

Installer Zenphoto sur Free , le 16 janvier 2006 par Miles

Je ne vois pas en quoi la page est mise à jour. Tu sites toujours la version 0.9

Installer Zenphoto sur Free , le 16 janvier 2006 par dolichocéphale

??? je précise que seul est à jour pour l’instant le tutoriel sur ma page : http://dolycho.free.fr/tuto/zenphoto_free.html

Si tu vois toujours le tutoriel pour zenphoto 0.9, peut être qu’un rafraichissement du navigateur résoudrait le problème (touche F5) !

Installer Zenphoto sur Free , le 16 janvier 2006

Je suis désolé mais j’ai relu ton tutoriel, je ne vois pas de différence et c’est toujours la version 0.9 qui est citée ;)

Installer Zenphoto sur Free , le 17 janvier 2006 par de passage

Va voir un opticien  :)

Installer Zenphoto sur Free , le 17 janvier 2006

yesss ! ça marche ;)

Installer Zenphoto sur Free , le 17 janvier 2006 par dolichocéphale

l’opticien ? :)

Répondre à ce message

les photos ne s’affichent pas , le 14 janvier 2006 (2 rép.)

Bonjour,

Installation réussie sur Free mais les photos ne s’affichent pas. Quelqu’un aurait-il rencontrer le même problème ?

les photos ne s’affichent pas , le 15 janvier 2006 par Seb

oui moi ! tout fonctionne au cours de l’installation sauf que je n’ai pas de miniature effectivement.... si quelqu’un a une solution...

les photos ne s’affichent pas , le 16 janvier 2006 par dolichocéphale

bonjour, je ne sais pas d’où vient votre problème, normalement Zenphoto génère automatiquement les vignettes. Peut-être y a-t-il une limitation en taille ou poids des images uploadées ? Avec des images de 500x350 pixels et de 200ko, cela fonctionne parfaitement. Serait-il possible de donner l’adresse d’une de vos photos pour vérifier si cela fonctionne sur mon site test ou si cela provient de votre installation ?

NB le premier tutoriel s’appliquait uniquement à la version 0.9 de Zenphoto. Je l’ai remis à jour pour la nouvelle version 1.0.1 (voir message ci-dessus).

Répondre à ce message

Installer Zenphoto sur Free , le 11 janvier 2006 par JeanP (3 rép.)

Voila j’ai suivi le tutorial pas à pas et au moment de faire http://monsite.free.fr/zenphoto/zen/setup.php j’ai le message suivant :

Internal Server Error The server encountered an internal error or misconfiguration and was unable to complete your request.

Apache/ProXad [Jan 5 2006 14:23:29] Server at monsite.free.fr Port 80

Une idée du pourquoi ? Free me dit que ma base est activé, le log et pass sont celui que j’utlise pour le ftp donc valide, j’ai vérifié la syntaxe

Merci de votre aide.

Installer Zenphoto sur Free , le 11 janvier 2006 par JeanP

Autant pour moi j’avais oublié de supprimer .htaccess dans le repertoire /zenphoto

desolé. a+

Probleme d’instalation , le 17 janvier 2006 par nainnain6

Bonjour donc moi toute l’instalation cs bien passé mais au moment d’aller administrer je recoi ce msg d’erreur Error : The ’albums’ directory cannot be found or is not readable

alors si quelqu’un pouvait m’éclairer pasque je ne sait pas trop quoi faire merci d’avancel

Installer Zenphoto sur Free , le 18 janvier 2006 par kongasiou

Aprés le login ?ou juste aprés l’install ?

Dean

Répondre à ce message

Informations complémentaires

Faire un don ? (défiscalisé)

Faire un DON

Aidez-nous à atteindre notre objectif de 800 donateurs récurrents pour assurer notre pérennité et notre développement ! (nous n’y sommes plus très loin).

Je soutiens Framasoft pour 10€/mois

Informations générales

Juste une image

IMG_0896.jpg IMG_0896.jpg
Creative Commons BY-SA